Workshop and Prologue bug

So tried the game for the first time today. Got to the Dungeon prolog level and beat it. When I beat it I was told to go to the workshop and upgrade my spike traps. However when I got to the workshop it showed no UI to upgrade and froze. I had to kill the game and restart. When I restarted it said I had not completed the Dungeon level so I replayed it. When I completed it again I was once again told to upgrade my spike traps. This time going to the workshop it displayed a new visual to upgrade but locked up immediately again. I had to kill the game and replay the dungeon again. However this time I decided to beat the level and ignore the workshop. Comically the game read my mind as I beat the level I was no longer shown the workshop button at the top of the screen. However I can no longer play because the next level requires me to upgrade my traps in the workshop.

Windows 7 x64, Radeon R9 270x, 10gigs of RAM...so on and on.
Post edited by nPHYN1T3 on

Comments

  • Did you try skipping the prologue? You can replay it later if you want... Devs should take a look at this, but maybe you can play in the meanwhile by skipping it altogether :)
  • edited February 24
    Wasn't there a bug awhile ago that was causing this @Jacowboy ? I don't remember the specifics, but I feel like this happened to someone before.

    *edit*: I looked for it, and I found what seems to be unrelated, this: https://forums.orcsmustdie.com/discussion/11673/patch-1-6-stuck-on-2nd-prologue#latest

    Sadly, I think that's what I was thinking of. So sorry, I dunno how to fix your issue nPHYN1T3.
    Post edited by Juicy on
    Wiki Contributor: Juicearific - Got a wiki suggestion? Let me know.
    Welcome to Juicy's Midnight Assassination Service. You grab em, I'll stab em.
  • I don't remember reading about it... maybe =/
  • Ya I tried to skip the prologue but it locks up just the same, I can't play at all now. I know they just patched but this issue is still there for me. I guess I'll wait and see if anything changes a few patches down the road.
  • @Winwin do you know anything he could try to fix this?
    Wiki Contributor: Juicearific - Got a wiki suggestion? Let me know.
    Welcome to Juicy's Midnight Assassination Service. You grab em, I'll stab em.
  • I just launched the game to see if maybe there has been an update/patch and I get audio and a bright fuchsia screen good ol' 255 0 255 and it locks up and stops responding. Someone better tell Robot's dev team the orcs are winning ;p heh.
  • I can tell you to put in a support ticket by going here: https://orcsmustdie.com/#!/en/support/contact-us
    And following the steps it lays out. Otherwise, I poked a dev for you to see if they know anything.

    Hope this gets sorted for ya!

    Wiki Contributor: Juicearific - Got a wiki suggestion? Let me know.
    Welcome to Juicy's Midnight Assassination Service. You grab em, I'll stab em.
  • Hey nPHYN1T3,

    Sorry that we haven't gotten you any information on this, your post slipped through the cracks! Our support team would love to help if you're still experiencing the issue. Please contact them and provide all of these details so they can assist you!

    http://support.orcsmustdie.com
    Robot Entertainment | Community Manager
  • edited March 7
    Juicy said:
    @Winwin do you know anything he could try to fix this?
    @nPHYN1T3 - I'm sorry for the delay in getting back to you!

    Since the game froze on you, we will need to check your installation and make sure your drivers are current.

    Please try the following:

    1. Verify there are no problems with your installation.
    • If you're playing via Steam, go to the Library tab, right click OMDU, select Properties, then Local Files, and then click on "Verify Integrity of Game Files".
    • If you're using the Standalone client, try using the repair function detailed here
    2. Flush your config files per the instructions detailed here.

    3. Make sure to shut down all external programs. If you're running an antivirus or firewall, please disable them before loading the game.

    4. Make sure you have the most recent video drivers installed on your system. 

    5. If the issue persists after that, try reinstalling Visual C++ and Direct X for Windows 7 via the instructions here.

    If none of those steps help, we will need to see your DxDiag and log files for further investigation. Details on how to find those files and open a ticket with us can be found here.
  • edited March 7
    Hey quick update. I just decided to try a few things, most have been outlined above. I did a steam local file verify and then I was going to delete user profiles etc. Drivers are all current but I had something else happen this time. I launched the game, got that Fuchsia screen I mentioned with audio. However this time when it stopped responding I killed it and the audio kept going. I searched to kill the file process but there was no file process. I checked open audio streams and it was a Steam Web Helper that was keeping the audio going despite the game being dead. Not sure if that matters to you guys.

    Another thing I was going to mention is the game ignores the primary monitor which is annoying. I know right now the game is very compartmentalized with various dos prompts popping up to run scripts and such but this is something that reminds me of omd2. OMD2 the scaling and distance to character was fixed based on screen size so any time you try to play on a screen bigger than 1920x1080 your character is under the camera. Little things like this seems to get missed in development so I figured I'd mention that the game should be aware of multimonitor set ups rather than assume there is only one screen and default to left most or "1" despite it not being the primary monitor.

    As a last note I deleted all the spitfire* files in my config directory and the game launches with the actual background now and a short audio file plays but then it locks up again with "loading" at the bottom and the steam overlay notice frozen in the panel the login and such is rendered in. I'll make a ticket with my dx log.

    Wiped all orcs unchained files from my system and entries from registry, nuked from steam and reinstalling to test. I've submitted a ticket so I guess we'll see if anything comes of it.
  • @nPHYN1T3 - I got your ticket and will be in touch with you shortly -- thanks! 
  • K thanks, my wipe and reinstall didn't help. When the game launched while it showed the login for a second before it locked up it seemed like it still had account info to auto login with so I'm not sure if I missed something in the registry or file system. I hunted down all the orcsmustdie references in the registry and file system along with robot and spitfire. Is there anywhere else I might look to wipe things clean to test? Also might be worth mentioning when I did the "clean" install after wiping things it hung before creating the orcs/spitfire directory again in my games.
  • edited March 8
    @nPHYN1T3 - OMDU accounts are linked to the Steam profiles they're played through, so it should log you in automatically. I replied to the ticket you opened with us with some further troubleshooting steps, did you receive the email? If so, please reply to the email and let me know which steps from it you tried specifically -- I'll keep investigating further! :)
  • Just checked, keeps flagging your emails as spam even though I keep marking as not spam. I'll reply to the email.
  • edited March 8
    @nPHYN1T3 - A lot of email providers have very strict filters in place to prevent spam. If our emails are getting caught in it, I recommend adding us as a trusted contact. That way, if you ever need help in the future, you'll be sure to receive our messages! :)

    Note: As we are working together in a support ticket, I'm going to go ahead and lock this thread. Please make sure to send any further updates through the support system so we can get this fixed for you.
    Post edited by Winwin on
This discussion has been closed.