Help please

Just bought into the Beta, signed up, downloaded, etc. The problem I'm having is after I login through the Client and the "End user license agreement" screen comes up... I am on a Toshiba laptop, and I can't maximize the screen to hit the "I accept" button that should be at the bottom of the agreement screen. There is NO option to maximize the End user license agreement screen. I cannot play the game, I have tried all resolution options, and it doesn't seem to help. I would like to be apart of this game's development but Idk how to get through this problem. I have tried to hover my mouse near the edges of the End user license agreement box that pops up, but there is no "size scaling" option. :(. Any ideas????


  • MitchellWMitchellW Member, Moderator, Early Access
    Glad you are excited about the game! The easiest way to get you into the game will be to change your desktop resolution so that the entire EULA appears. You can do this temporarily just so you can click yes, and then change it back so it doesn't mess with your system performance.

    Just to be sure, your laptop meets the system requirements for the game?

    If this doesn't work for you, I believe there's something in a coming patch that will help, but I'm not sure it's the next one, I will check up on that!
  • Yes this laptop, although not a gaming laptop, does quite well for all of my games that I play. Skyrim, League of Legends, Heroes of the Storm, Planetside, etc. I finally figured it out! The client would start up in a box and it took me a while to figure out how to take it from a small minimized window to full screen, problem resolved! Thank you for assisting me.
  • MitchellWMitchellW Member, Moderator, Early Access
    Glad you've got it working!
Sign In or Register to comment.